Templates

Templates can be accessed from File ▸ New from Template menu or Window ▸ Welcome to Retrobatch. Be sure to read the Basics page to learn how to add and modify workflows and write images. Contact us if you have suggestions for other workflow templates we should include, or if you need help putting one together.

Each workflow below is shown in the format of the node name with an arrow indicating a directional link to the next node. For example: Node name → node name → node name.

Available Templates Include:

Capture Date on Photos:

Read Folder → Text Watermark → Write Images

Drag and drop a folder of images onto the Read Folder Node. Click on the Text Watermark node to add the capture date, or any other text to watermark images. For additional options, click on the cogwheel in the inspector palette and a drop-down menu of tokens are available including current date, capture date, copyright and author. Add a 'Set General Metadata' node before the 'Text Watermark' node to quickly edit copyright and author information which can then be used for a text watermark if desired. Click on the Write Images Node and click on 'Choose' in the inspector to select a folder to write your images into.

Convert HEIC images to JPEG

Read Folder → Rules → Write Images

Drag and drop a folder of images onto the Read Folder node. The Rules node is set up so that if any images in a folder are .heic or .heif, they will be converted to the file type you select in the Write Images node. Click on the Write Images Node and click on 'Choose' in the inspector to select a folder to write your images into.

Hot Dog or Not?

Read Folder → Classify Images → Rules → Write Images

The Rules node is set up to pull out any images whose classification includes 'hotdog'. Image classification information can be found by clicking on an image in the scrubber, then clicking the 'i' in the lower righthand corner of the window. To start, drag and drop a folder of images onto the Read Folder node. Click on the Write Images Node and click on 'Choose' in the inspector to select a folder to write your images into.

PNG Crush and sRGB

Read Folder → Change Color Profile → Write Images

Drag and drop a folder of images onto the Read Folder node. The Change Color Profile node is set up to change the color profile to sRGB if it isn’t already, and then saves the images as optimized PNGs. The PNG step is very intensive, and can take a while to run. In addition, PNGs are stripped of their color profile to save on space. Most browsers will default to sRGB if a profile is not present. Click on the Write Images Node and click on 'Choose' in the inspector to select a folder to write your images into.

Social Scrub

Read Folder → Remove GPS → Delete Metadata → Write Images

This workflow is useful for removing all identifying information from an image including its GPS location, date, time, etc. Perform this workflow prior to uploading images to social media to minimize identifying information being shared. Drag and drop a folder of images onto the Read Folder node. Click on the Write Images Node and click on 'Choose' in the inspector to select a folder to write your images into.

Windows to PSD

Screenshots & Windows → PSD Maker → Write Images

The Screenshots and Windows node takes a screenshot of either one image per window or one image per screen. All windows present in the screenshot will be placed into a multi-layer PSD file. Click on the Write Images Node and click on 'Choose' in the inspector to select a folder to write your images into.

Creating and Deleting Custom Templates

Retrobatch comes preloaded with templates that suit common workflows. To create a custom template:

  • Create a workflow of the template you want in the canvas.
  • Go to File ▸ Save, name the file, and save it to a location.
  • Navigate to File ▸ New from Template ▸ Open Templates Folder.
  • Drag and drop your template file into the Workflow Templates folder.

To delete a template, go to File ▸ New from Template ▸ Open Templates Folder and click on the template file name and hit the command key and the delete key together, or drag and drop the file to the trash.