Acorn Acorn 5

Using Filters in Acorn  



Filter Introduction


Filters are an amazingly easy way to change your image in original and unique ways.  What are filters?  Filters are effects that can be applied to single layers, group layers, shape layers, and selections.  With a little bit of fiddling, filters can create things you never even imagined! 


To get started, select the layer you wish to work with in the layers list. This example will use an image of a sunflower. 


Bring up the filter window by either picking a filter from the filter menu item or clicking the 'fx' button in the lower left hand corner of the inspector palette.  You can also use keyboard shortcut ⇧⌘F.  


In the example below to the right, Filter ▸ Tile Effect ▸ Kaleidoscope was chosen.  Acorn shows the effect the filter has on your image immediately.


Once you have chosen filter, you will see 'fx' on the right-hand side of the layer in the layers list.  


filters0.jpg


If you need to change the values of the filter later, just return to the filters window by double clicking the 'fx'.  If you wish to make a filter effect permanent, select 'Flatten' in the filters window.  Once you have flattened a filter, you will no longer have the ability to modify it and the 'fx' will disappear from that layer in the layers list.  


The power of the filter window comes in stacking filters together to make workflows.  In the image below, the 'hue adjust' filter has been added on top of the kaleidoscope filter.  Play around with adding, deleting, and moving filters around in your filters window to create endless effects! 

Screen Shot 2015-05-07 at 10.11.50 PM.png

Screen Shot 2015-05-04 at 1.52.50 PM.png

filters3.jpg


Filter Basics


Adding Filters:   Once you have selected a filter, you can add more filters to the same layer by clicking on the '+' button in the lower left hand corner of the filter window.  


Removing Filters: To remove any filter, click on the 'X' in the upper right hand corner of that filter’s parameters. 


Moving Filters:  To move a filter up or down in the filters list, just drag and drop it to the location you desire.


Search Filters:  The first time you click the 'fx' button, the filter search field will appear.  Once you've added a filter, you can click the '+' button again to access filter search.


Copying Filters: To copy a filter, click on the cogwheel in the lower lefthand side of the filter window and choose 'Copy filter'.  You can then select a different layer in your layers list and paste the filter in (⌘V or Edit ▸ Paste). 


Committing Filters: To make the filter effect permanent on your layer, click the 'Flatten' button at the bottom righthand side of the filter window.  You can also choose Layer ▸ Flatten Layer Filters.  To flatten all filters across multiple layers present in your image go to the Layers menu item, hold down the option key, and the "Flatten Layer Filters" menu item changes to "Flatten All Layer Filters".  You can leave your filter effects open to further modification in the future if you don't click 'Flatten'.  


Visibility:  Click on the eye next to the filter in the filter window to toggle its visibility.  If you wish to toggle the visibility of all the filters in your list you can hold down the option key while clicking the 'fx' in the layers list.  


Reseting Filter Values:  You can reset all the values in a filter by clicking the circular arrow located between the filter visibility and delete buttons.  To reset individual values in a layer filter double click on that values name label.


Enable/Disable Layer Filters: Control click (or right click) on the layer in the layers list to bring up a contextual menu with these options.  You can also navigate to Layer ▸ Enable/Disable Layer Filter.


Filter Description:  If you select a filter in the filters window, a brief description will appear at the bottom of the window.


Last Filter:  The Filter ▸ Last Filter menu item is enabled when when you hit the "Flatten" button in the filter window. You can then use keyboard shortcut Command-F to add the last filter chain to another layer.

filters4.jpg



filters5.jpg






Adjusting Filter Parameters  


Many filters have values you can adjust in the filters window through sliders or number entry.  Some filters contain options that can be manipulated directly on your image such as the 'Center' and 'Radius' options for the radial gradient filter.  To toggle the visibility of 'on image' filter controls, click the button to the right of the cogwheel in the lower left hand corner of the filter window.


filters6.png


You can also see how this works in the filters video tutorial: Filters Basics.  


filters7.jpg




Creating, Exporting, and Importing Filter Presets


Creating Presets:  In order to create a filter preset, first add all the filters you want included in the preset to your filters list.  Then click on the cogwheel and select 'Save FilterPreset'.  Name your new preset and click 'save'.  The filter combination you created will now show up in the presets list for easy use in the future.  


Deleting Presets:  To delete a preset, hold down the option key while clicking on the preset in the preset list.  


Exporting Presets: To export a filter preset, have the preset currently pulled up in the filter list.  Click on the cogwheel and select 'export filter preset'.  You will be asked to name it and save it to a directory.  Share and trade your filterpresets with friends!  


Importing Presets:  To import a filter preset (a file ending in .acstyle) just double click on the file.  Acorn will install it automatically.  




Filters on a Selection  


Filters can be placed on a selection, but once you deselect the filter becomes permanent and cannot be modified again unless you undo subsequent work.  To bring up additional options for filters on selections, click on the cogwheel located on the lower left-hand corner of the filters window.  Options include:

Blend with canvas selection:  This is the standard behavior when applying filters to the selection. Acorn will apply your filter(s) to the currently selected area on your bitmap layer, and then draw the results of that filter over your layer.

Copy over canvas selection:  This option will apply your filters to the current selection, and then replace the pixels in your selected area with the results of the filter. For example, if the filter returns transparent pixels, your layer will become transparent in those areas.


Ignore canvas selection:  This option will ignore the canvas selection, and the filter will be applied over your entire layer.

Acorn will remember your selection when you save your image.  If you have a selection and you are modifying the filters- you can close your file and quit Acorn. When you re-open the image, your selection will still be there, and you can change the values of the filters.



Filter Example



A drop shadow filter is applied to the gray background layer in this image.  


filters8.jpgScreen Shot 2015-05-04 at 2.13.35 PM.png


The drop shadow filter is applied to the text layer.  The gray background is a separate layer therefore it does not have the drop shadow.


filters10.jpgScreen Shot 2015-05-04 at 2.12.08 PM.png



Try playing around with some of the filters and experiment, experiment, experiment.  For more information, check out the Tutorials or send an email to support@flyingmeat.com and request a tutorial.



See Also:  Filters Basics (video tutorial) Drop Shadows, Filter Examples, Extra Plugins